new member

Jun 9, 2024
1
1
Rochester ny
Name
Ed
hello all ty for allowing me in. I have a 1996 gl1500 trike and it wont start now. Drove here from buyers house and shutdown as soon as i got in my driveway. Amp gauge said 9.0 which i know is low just don't what happened or how to fix the problem. any help would be awesome thank you the new bear
 
hello all ty for allowing me in. I have a 1996 gl1500 trike and it wont start now. Drove here from buyers house and shutdown as soon as i got in my driveway. Amp gauge said 9.0 which i know is low just don't what happened or how to fix the problem. any help would be awesome thank you the new bear
Welcome to Trike Talk…..First thing you should do is try to charge the battery 🔋…And if it starts…Get a new battery 🔋… other than that without more information about how it sounds when you turn the key to start it that’s all I can help you with it…
 
welcome aboard. need to check the alternator and associated parts circuits. Sounds to me like you were able to get it home on battery power. Once that got to low to run things it will not start. I bet if you charge the battery it will start nd run but on battery only. Need to find problem in charging system. Good Luck
 

Welcome to the Trike Talk Community

Join our vibrant online community dedicated to all things Trikes! Whether you're a seasoned rider or just starting out, this is the place to share experiences, tips, and stories about your three-wheeled adventures. Explore modifications, maintenance advice, and rides, all while connecting with fellow trike enthusiasts from around the globe

Forum statistics

Threads
55,273
Messages
786,036
Members
22,737
Latest member
Tmorri1
Back
Top